Saturday, October 8, 2011

REDISTRIBUTION USING OSPF AND EIGRP

Redistribution helps us to inject the routes learnt by one routing protocol in one autonomous system into the another routing protocol having different autonomous system.With the help of redistribution we can join two different network having two different routing protocols communicate.


here in this scenario R1 is running ospf and R3 is running eigrp and R2 will be running both the protocols.

configuration
R1
enable 
configure terminal
int fa 0/0
ip add 10.11.11.1 255.255.255.0
no shut
int lo 0
ip add 1.1.1.1 255.0.0.0
router ospf 1
network 10.11.11.0 0.0.0.255 area 0
network 1.1.1.1 0.0.0.0 area 0
no au
end

R3
enable 
configure terminal
int fa 0/0
ip add 10.22.22.3 255.255.255.0
no shut
int lo 0
ip add 2.2.2.2 255.0.0.0
router eigrp 10
network 10.22.22.0
network 2.0.0.0
no au
end

R3

enable 
configure terminal
int fa 0/0
ip add 10.11.11.2.255.255.255.0
no shut
int fa 0/1
ip add 10.22.22.2 255.255.255.0
no sh
router ospf 1
network 10.11.11.0 0.0.0.255 area 0
no auto-summary
router eigrp 10
network 10.22.22.0
no auto-summary
-----------
REDISTRIBUTION 

R2(config)router ospf 1
R2(config-router)#redistribute eigrp 1000

R2(config-router)#exit
R2(config)#router eigrp 10
R2(config-router)#redistribute ospf 1 10000 1000 255 1 1500






 

Tuesday, April 19, 2011

STUB / TOTALLY STUB


STUB

Stub area is created inorder to stop redistributed routes into an ospf area , that means type 5 lsa's are not allowed which are generated due to redistribution.Creating an area stub makes the abr generate default route which is pointing towards itself


The best way of presenting a topology with stub area is shown below


click on the image to view large




In this topology area 0 will have OE2 routes in the routing table. OE2 routes are the redistributed routes from eigrp autonomous system into ospf.

Since area 1 is stub area, so type 5 lsa are not allowed.so abr will inject default route pointing towards itself in R4 ( fig ).so only OIA* route will be seen along with the inter-area routes.

If lsa type 3 are to be blocked then typing the command on the abr will block lsa type 3 also and default route is injected pointed towards abr.



Configuration for creating stub area(based on the figure above)


R4


router4>
router4>en
router4#conf terminal
router4(config)#router ospf 1
router4(config-router)#area 1 stub


R5


router5>
router5>en
router5#conf terminal
router5(config)#router ospf 1
router5(config-router)#area 1 stub


Configuration for creating totally stub area(based on the figure above)


R4
router4>
router4>en
router4#conf terminal
router4(config)#router ospf 1
router4(config-router)#area 1 stub no-summary


R5

router5>
router5>en
router5#conf terminal
router5(config)#router ospf 1
router5(config-router)#area 1 stub no-summary




Wednesday, March 23, 2011

Ipv6

Ipv6
Ipv6 is a 128 bit logical address assigned to layer 3 devices like computers, routers etc.Ipv6 is also called new generation address.Ipv6 can be represented as 2001:1:1:1:2:2:2:2 .Ipv6 does not support broadcast,but it uses multicast, unicast and anycast to forward packets(data).

Configuring rip with ipv6

Inorder to configure rip with ipv6,advanced rip protocol called RIPNG (rip next generation) is used.

Scenario

Two routers connected to each other with their loopbacks (logical interfaces) enabled on each router.


Router A's interface address 2001::1:1:1:1:1
Router A's loopback address 2001::2:1:1:1:1
Router B's interface address 2001::1:1:1:1:2
Router B's interface address 2001::3:1:1:1:1

Configuration

Router1>Enable
Router1#conf terminal
Router1(config)#int s 0
Router1(config)#ipv6 unicast-routing     (to enable ipv6 in routers)
Router1(config-if)ipv6 address 2001::1:1:1:1:1/64
Router1(config-if)#no shutdown
Router1(config-if)exit
Router1(config)#interface loopback 0
Router1(config-if)#ip adress 2001::2:1:1:1:1/64
Router1(config-if)#no shutdown
Router1(config)#exit

Router1>Enable
Router1#conf terminal
Router1(config)#int s 0
Router1(config)#ipv6 unicast-routing     (to enable ipv6 in routers)
Router1(config-if)ipv6 address 2001::1:1:1:1:2/64
Router1(config-if)#no shutdown
Router1(config-if)exit
Router1(config)#interface loopback 0
Router1(config-if)#ip adress 2001::3:1:1:1:1/64
Router1(config-if)#no shutdown
Router1(config)#exit



Configuring ripng

Router1(config)#interface s 0
Router1(config-if)#ipv6 rip 1234 enable
Router1(config-if)#exit
Router1(config)#interface loopback 0
Router1(config-if)#ipv6 rip 1234 enable
Router1(config-if)#exit

Router2(config)#interface s 0
Router2(config-if)#ipv6 rip 1234 enable
Router2(config-if)#exit
Router2(config)#interface loopback 0
Router2(config-if)#ipv6 rip 1234 enable
Router2(config-if)#exit

To check the routing table
use
Show ipv6 route ( under priveledge mode)

ping loopbacks
example


ping 2001::3:1:1:1:1
or ping 2001::2:1:1:1:1

Wednesday, February 2, 2011

FRAME-RELAY

Frame-relay is a layer 2 technology to create vpn based network.It supports the data rate of 1.544 MBPS and to the maximum of 44 MBPS.Frame-relay cloud is a pool of bandwith supporting bursty nature of data. In frame-relay no error correction, error detection are implemented.In this technology the end devices are connected to the switching network called frame-relay cloud.Frame-relay cloud is the collection of frame-relay switches,the purpose of frame-relay switches is to transfer the packets across the virtual circuit implemented in the frame-relay cloud.
The DTE end to which the end devices are attached is connected to the Csu/Dsu device which in turn is connected to the frame-relay switch which is a DCE device.The clock rate is set on the dce device.The path to the destination in the virtual circuit is identified by DLCI(data link connection identifier) which are set at the ISP end.




Implementing Frame-relay on cisco routers

This is the configuration for NBMA rfc standard.
In this configuration neighbours are not discovered dynamically and there is the contest for DR/ BDR.







Scenario

connecting R1 R2 and R3 across the framerelay cloud.

Configuration

framerelay router as a frame-relay switch

r>en
r#conf t
r(config)#hostname fr-sw
fr-sw(config)#frame-relay switching
fr-sw(config)#int s 1/0
fr-sw(config-if)#encapsulation frame-relay
fr-sw(config-if)#frame-relay intf dce
fr-sw(config-if)#frame-relay route 102 interface serial 1/1 201
fr-sw(config-if)#frame-relay route 103 interface serial 1/2 301
fr-sw(config-if)#clock rate 128000
fr-sw(config-if)#no shutdown
fr-sw(config-if)#exit
fr-sw(config)#int s 1/1
fr-sw(config-if)#encapsulation frame-relay
fr-sw(config-if)#frame-relay intf dce
fr-sw(config-if)#frame-relay route 201 interface serial 1/0 102
fr-sw(config-if)#clock rate 128000
fr-sw(config-if)#no shutdown
.
.

fr-sw(config)#int s 1/2
fr-sw(config-if)#encapsulation frame-relay
fr-sw(config-if)#frame-relay intf dce
fr-sw(config-if)#frame-relay route 301 interface serial 1/0 103
fr-sw(config-if)#clock rate 128000
fr-sw(config-if)#no shutdown
fr-sw(config)#exit



commands associated for troubeshooting

show frame-relay route
show frame-relay pvc

router configuration

R1>en
R1#conf terminal
R1(config)#hostname hub
hub(config)#int s 1/0
hub(config-if)#encapsulation frame-relay
hub(config-if)#ip address 10.0.0.1 255.0.0.0
hub(config-if)#no shut
hub(config-if)#int lo 0
hub(config-if)#ip add 1.1.1.1 255.0.0.0
hub(config-if)#exit
hub(config)#int s 1/0
hub(config-if)#frame-relay route map ip 10.0.0.2 102 broadcast
hub(config-if)#frame-relay route map ip 10.0.0.3 103 broadcast
exit
hub(config)#router ospf 10
hub(config)#network 10.0.0.0 0.0.0.255 area 0
hub(config-router)#network 1.1.1.1 0.0.0.0 area 0
hub(config-router)#neighbor 10.0.0.2
hub(config-router)#neighbor 10.0.0.3
exit


R1
R1#conf terminal
R1(config)#hostname spoke1
spoke1(config)#int s 1/0
spoke1(config-if)#ip add 10.0.0.2 255.0.0.0
spoke1(config-if)#no shutdown
spoke1(config-if)#int lo 0
spoke1(config-if)#ip add 2.2.2.2 255.0.0.0
spoke1(config-if)#exit
spoke1(config)#int s 1/0
spoke1(config-if)#encapsulation frame-relay
spoke1(config-if)#frame-relay route map ip 10.0.0.1 201 broadcast
exit
spoke1(config)#router ospf 10
spoke1(config)#network 10.0.0.0 0.0.0.255 area 0
spoke1(config-router)#network 2.2.2.2 0.0.0.0 area 0
spoke1(config-router)#neighbor 10.0.0.1
exit

R3
R3#conf terminal
R3(config)#hostname spoke2
spoke2(config)#int s 1/0
spoke2(config-if)#ip add 10.0.0.2 255.0.0.0
spoke2(config-if)#no sh
spoke2(config-if)#exit
spoke2(config)#int lo 0
spoke2(config-if)#ip add 3.3.3.3 255.0.0.0
spoke2(config-if)#int s 1/0
spoke2(config-if)#encapsulation frame-relay
spoke2(config-if)#frame-relay route map ip 10.0.0.1 301 broadcast
exit
spoke2(config)#router ospf 10
spoke2(config)#network 10.0.0.0 0.0.0.255 area 0
spoke2(config-router)#network 3.3.3.3 0.0.0.0 area 0
spoke1(config-router)#neighbor 10.0.0.1
exit

Tuesday, January 25, 2011

Authentication/Authorization/Accounting

Authentication is the process of identifying who the entity is or what it claims to be. Example To log in into the computer we need user-name and password, this is authentication.
Authorization is which resources a user or an entity can access.
Accounting keeps track of all what resource have been accessed and for what interval.


Rip version2 supports authentication. It authenticates the route updates. Rip authenication can be plain or encrypted using MD5

configuration for plain text authentication

r>enable
r#conf t
r(conf)#key chain ring
r(conf-keychain)#key 1
r(conf-keychain-key)#key-string cisco
r(conf-keychain-key)#exit
r(conf)#int s0/0
r(conf-if)#ip rip authentication key-chain ring



configuration for MD5 authentication

After configuring the key chain and key string use MD5 authentication under an interface

r(conf-if)#ip rip authentication mode MD5


Eigrp supports only Md5 authentication

Configuration

r>enable
r#conf t
r(conf)#key chain ring
r(conf-keychain)#key 1
r(conf-keychain-key)#key-string cisco
r(conf-keychain-key)#exit
r(conf)#int s0/0
r(conf-if)#ip authentication eigrp 10 key-chain ring
r(conf-if)#ip authentication eigrp 10 mode Md5

Injecting Default routes


Injecting default route...
The purpose of injecting default route into an Eigrp process is to make the routers under the routing protocol to point to the router on which default route is configure.
There are different ways to do this.
1)Default-information originate:-
This command is used to inject the default route into the rip process, so as to make the routers to point towards the router on which command is set or we can say that this command enables router under the protocol (rip etc) to point towards the router on which default-information originate is set
2)Redistribution.
3)IP Summary-address.
Injecting default route using redistribution.

Scenario
3 routers A,B and C running Eigrp protocol and router A is an edge router pointing towards ISP and default route is configured on router A

Configuration.

RouterA>enable
RouterA#conf t
RouterA(config)#router eigrp 10
RouterA(config-router)#redistribute static
RouterA(config-router)#CTRL+Z
RouterA#



Configuration for Default information originate for same scenario

RouterA>enable
RouterA#conf t
RouterA(config)#router rip
RouterA(config-router)#version 2
RouterA(config-router)#default-information originate
RouterA(config-router)#CTRL+Z
RouterA#

Configuration for Summary Address



RouterA>enable
RouterA#conf t
RouterA(config)#int s0/1
RouterA(config-if)#ip summary-address eigrp 10 0.0.0.0 0.0.0.0
RouterA(config-if)#CTRL+Z
RouterA#

Friday, January 14, 2011

configuring passive interface in eigrp

Passive interface in Eigrp

Configuring passive interface in eigrp does not work like rip. However in eigrp, inorder to send unicast updates we need to add the neighbour router interface ip address under interface mode.


router1>en
router1#conf terminal
router1(conf)#interface s 0/0
router1(conf-if)#neighbor 10.0.0.2 s0/0

similar is the configuration for router2
and u will have unicast updates send across the neighbor routers.


Route summerization.

Summerization is done inorder to decrease the size of routing table...
so as to save bandwidth and to stop sending updates due to flapping of any network.


Scenario:

A router with 3 loopbacks and and serial interface...
objective:Sending of summerized route through the interface

Configuration
router>en
router#configure terminal
router(config)#int serial interface 0/0
router(config-if)#ip address 10.0.0.1 255.0.0.0
router(config-if)#no shutdown


router(config)#int loopback 0
router(config-if)#ip address 1.1.1.1 255.255.255.0
!
router(config)#int loopback 1
router(config-if)#ip address 1.1.2.1 255.255.255.0
!
router(config)#int loopback 2
router(config-if)#ip address 1.1.3.1 255.255.255.0
!
router(config)#router eigrp 10
router(config-router)#net 10.0.0.0
router(config-router)#net 1.1.1.0
router(config-router)#no auto-summary
router(config-router)#exit
router(config)#int s 0/0
router(config-if)#ip summary-address eigrp 10 1.1.1.0 255.255.252.0

Monday, January 10, 2011

Cross Cable

One End of the Cable                Second End of the Cable


White Orange                              white green
Orange                                        green
white Green                                 white orange
blue                                             blue
white blue                                    white blue
Green                                          orange
white brown                                white brown
Brown                                         brown

Routing protocols

There are two types of protocols.
1.Routed  2. Routing
Routed protocols are those protocols which are meant to carry information to the required destination like IP , IPX etc.
Routing protocols are meant for finding all possible routes in the internetwork. like Rip , Igrp, Eigrp, Bgp

Routing is the process of finding the route to reach the destination in the internetwork.
Routing can be static, dynamic and default.
Dynamic routing include routing protocols which automatically find the routes in the network.
Dynamic Routing Protocols can be either IGP or EGP.
Igp protocols are the protocols which are meant for a particular region, boundary or a single autonomous number. some of them include RIP, OSPF, EIGRP, IGRP..

BGP is the EGP protocol which is used between two different autonomous system or numbers and is meant for global networks.

Sunday, January 9, 2011

Layer 2 & layer 3 devices....

Switch is normally a layer 2 device. It populates its Mac table with mac entries of the devices to which it is connected by Broadcast at first, then multicast and finally with unicast. Switches are used to provide seperate collision domain in the network.

Routers and layer 3 switches are in the category of layer 3 devices.
Nomally layer 3 devices are all those devices to which ip address can be allocated, which includes computer as well.

Saturday, January 8, 2011

t1/t3

T1 and T3 are the types of leased lines
T1 is a high speed dedicated leased line for telecommunication..it provides speed up to 1.56Mpbs.

T3 is the combination of 28 t1 lines  for much higher speed ...